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A letter to the Desk of Editor
Hello friends!
After getting warm responses from every sphere of the world for our July issue, we are
encouraged to publish the August issue of the magazine. The present theme of the magazine is
Sketchup & photoshop
Photoshop is a noteworthy digital graphics editing application useful for graphics formation and
image manipulation whereas sketchup is the most popular 3D graphic program utilized to create
three dimensional models for conceptualization & design stage. By combining both a designer
can achieve excellence in design.
In this issue the readers will find an elite interview with Rhob Rondon, a promising sketchup vray artist. The readers will also find an interesting and informative cover story and a blog written
by sketchup ur space team focusing on in-depth analysis of how a designer can create great
image effects with sketchup and photoshop. In article section the readers will get an exclusive
article on how to make a conference room with sketchup v-ray and photoshop written by LIM
Rady, a renowned freelancer architect. Besides all these the readers will get also some
interesting stuffs on sketchup in the form of news, videos, tutorials etc.
Now sketchup has been acquired by big giant Trimble and we observe lots of development in
sketchup Trimble is already intensely involved in the AEC industry and SketchUp is putting its
step more elaborately into Engineering and Constuction,
For the sake of sketchup users Trimble has arranged several authorized training centers all over
the world. (http://www.sketchup.com/training/atc.html#classes). The sketchup users can
undergo some basic and advance course from here.
We found lots of advancement in sketchup. Sketchup is upgraded to sketchup pro 7 & 8
version. These new upgraded versions contain some unique features which are very useful for
home designing and landscape designing. Sketchup Pro comes up with 5 template containing
Plan View, Product Design and Woodworking, Engineering, Google Earth Modeling, and
Architectural Design. The sketchup users can apply each template for particular design tasks.
Sketchup Pro also facilitates quick and simple design of own custom models for the horticulturist
landscaper.
Hope that you will like this publication of Sketchup ur Space. We will eagerly wait to get
feedback from you. Please send me your suggestions at rajib@sketchup-ur-space.com.
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Best Wishes
Rajib Dey
Editor
Happy Reading!
THE GOAL OF EDUCATION IS THE ADVANCEMENT OF KNOWLEDGE AND THE
DISSEMINATION OF TRUTH

Sketchup and Photoshop - Enhance Your Design
Skill

- Debarati Nath
Photoshop is a powerful application on its own merits. Its power, however, can be significantly increased
by using it in tandem with another application like Illustrator, Cinema 4D, or in this case, Google
SketchUp. Today, we will create some cool 3D text using this free architectural application.
To create a daytime rendering by exporting images from SketchUp to Photoshop is a wonderful trick. This
means no external rendering programs are needed. This rendering is not meant to be realistic, but
instead, provide an option for quick artistic renderings without the "SketchUp" look.
It explores the idea of Ambient Occlusion shading to easily and quickly add realism to SketchUp images
via Photoshop. This is done without ever using a rendering engine such as MAX or VRAY. The idea
behind Ambient Occlusion is basically a really fast way of adding realism to a rendering by adding
shadows in corners where geometry meets. You will often see me adding this affect in a lot of the videos
may be created using the BURN tool in Photoshop. This video demonstrates how easy it is to get a really
cool effect using just images exported from SketchUp, and a few tools from Photoshop.
If any of you have watched the Kerkythea clay model tutorial, you will notice that you get a similar look.
The rendering engine is doing all of the work for you. The idea behind this new video is to show the power
of the BURN tool in Photoshop, and how it can be applied to architectural illustrations. If there isn’t a lot of
complex geometry in the image (in my case an aerial view of my design) than this method serves as an
option to bypass using a rendering engine such as Kerkythea altogether and still get a really nice looking
final result. Also, if your final illustration is looking a little flat, its an easy way to add a little punch to it.
Now we can have a discussion on how to merge SketchUp with Photoshop:
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It explores the idea of Ambient Occlusion shading to easily and quickly add realism to SketchUp images
via Photoshop. This is done without ever using a rendering engine such as MAX or VRAY. The idea
behind Ambient Occlusion is basically a really fast way of adding realism to a rendering by adding
shadows in corners where geometry meets. You will often see me adding this affect in a lot of the videos I
created using the BURN tool in Photoshop. This video demonstrates how easy it is to get a really cool
effect using just images exported from SketchUp, and a few tools from Photoshop.
If any of you have watched my Kerkythea clay model tutorial, you will notice that you get a similar look.
The rendering engine is doing all of the work for you. The idea behind this new video is to show the power
of the BURN tool in Photoshop, and how it can be applied to architectural illustrations. If there isn’t a lot of
complex geometry in the image than this method serves as an option to bypass using a rendering engine
such as Kerkythea altogether and still get a really nice looking final result. Also, if your final illustration is
looking a little flat, its an easy way to add a little punch to it.
As the title implies, this architecture illustration tutorial doesn't use a rendering engine. There are few
other tutorials in the past that don't involve a rendering program, however this tutorial does things a little
differently, and in less time. You will probably notice some similarities to the Ambient Occlusion tutorial
which was posted a while back. After making the ambient occlusion tutorial that could take advantage of
the export options of Sketchup, and use the line work of the model to generate the shading. Because of
this, the process is extremely streamlined and can be done in minutes.
Here's how it works,

Step 1
Begin by downloading the free version of Google Sketchup here. When you first open Sketchup, you’ll be
prompted with a dialog box asking what style to begin with. I have chosen the simple style, with blue sky
and green ‘grass’ (this is completely your preference, it will have no effect on your final outcome). Open
the main tool box by clicking View > Tool Palettes > Large Tool Set. There are a few tools we’ll make a lot
of use of, so it’s helpful to familiarize yourself with their shortcuts. These are the same on Windows and
Mac: select: (spacebar), push/pull: (p), offset: (f), orbit: (o), pan: (h), zoom: scroll up or down, or (z)
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Step 2
We need to create a template for where we’re putting our buildings. We’ll do this by viewing everything
from the top. To view from the top, go to Camera > Standard Views > Top. You should see the word
"Top" in the upper left corner after you do this. You’ll want your red and green axes pretty close, so zoom
in if necessary to get to a nice position (below). To grab the screen, use the pan tool (h) to help line
everything up.
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Step 3
Next, click on the 3D text tool and type in your text. Click on "Fonts" to change your font (thick stroked
bolder fonts work best), and input a size of 10" or greater. Then click "Place"
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Step 4
Now, click where you’d like to put your text on your canvas. If you want to move it after you place it, make
sure it’s selected (spacebar) + click, then click the move tool (m) and drag to the new location. If you’d like
to make your text bigger, make sure it’s selected (spacebar) + click, then click the scale tool (s), grab a
green node (a corner one to scale proportionally, they’ll turn red once selected), and drag until you’re
happy.
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Step 5
Now we need to put this on a separate layer. Unfortunately, this is a multi-step task, but a very easy one.
We need to start by opening our layers palette. Go to Window > Layers. Once the layers palette is open,
click the little "+" sign in the top left corner and name the new layer.
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Step 6
Next, with your selection tool (spacebar), right click on your text and choose "Entity Info." A small dialog
box will appear with a layer drop down menu. From this menu, choose the new layer you just named in
Step 5.
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Step 7
Your text has been officially moved. Feel free to close your "Entity Info" box, and if you wish, you can
check to make sure you put your text on the new layer by unclicking the little checkbox under "Visible" in
your layers palette. To be sure we put everything else on a different layer, make sure the radial button in
the layers palette near "Layer 0" is highlighted (the same as the image above). Now, time to get to
business!

Step 8
Select your rectangle tool (r), and zoom in nice and close to your first letter. Begin drawing squares and
rectangles to fill up your first letter. If you make a mistake, don’t worry. Cmd/Ctrl + Z will undo multiple
steps in the history. You can also select any rectangle and just hit your backspace or delete key to get rid
of it. Try your best each time you draw a new rectangle to share an edge with the previous one so there
are no gaps between your rectangles. Don’t forget you can make your template text visible and invisible
as you go to see your progress (in your layers palette, checkbox under "Visible"). Use the pan tool (h) to
grab the screen and move to the next letter. Do this for all of your letters.
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Step 9
Viola! All rectangled out! Go to your layers palette and make your template text invisible by unchecking
the "Visible" box beside it. Fill in any gaps you might have missed or delete any excess. Now it’s time to
texture. Go to Window > Materials to open the materials palette.
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Step 10
In your materials palette, choose "Brick and Cladding" from the drop down menu, then click on the
material you’d like to use for your buildings.
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Step 11
With your selection tool (spacebar) rubber band to select the area you’d like to texture with your chosen
material.
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Step 12
Next, grab your paint bucket tool (b) and click on any of the squares that are selected. The entire
selection will now be textured. If you are unhappy with the size of the texture, rubber band select all of
your letters, then use the scale tool (s), grab a corner green node (to scale proportionally), and resize until
you are happy with the size of the texture within your squares.
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Step 13
Texture the rest of your squares. You can also texture each square individually, if you’d like to put a
mixture of different textures together.
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Step 14
Now for the fun part! Grab your orbit tool (o) and orbit to an angle similar to the one below.
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Step 15
Next, grab your push/pull tool (p) and place it over one of your squares until it highlights. Click, then drag
upwards until you are happy with the height. Click to deselect. Move to the next square and repeat the
process.
TIP: When you pull next to a previously pulled segment and you attempt to pull higher than it, you’ll
receive an "Offset limitied to" red box (below). To continue pulling, click to end the segment, then click
again to raise it higher.
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Step 16
Keep pulling until you’re happy with your mini city of letters. Use your orbit tool (o), pan tool (h), and zoom
to scroll up and down, or (z), to navigate through and around all of your letters.
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Step 17
Once you have all of your letters pulled, it’s time to change up a few roofs to add a little visual interest and
detail. We’ll do this by using the offset tool (f). Zoom in closely to your first letter, grab your offset tool, and
get close to the edge of the roof you would like to adjust. Once on the edge, click and move the offset tool
inward, towards the center of the top of the building. You’ll notice new edges, forming what looks like a
border. Release the tool by unclicking when you are satisfied by the width.
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Step 18
Now, grab your push/pull tool (p) and once the center of the newly formed border is highlighted in blue,
push downward to create a rooftop. Repeat these steps to random building tops on all of your letters.

22

23

Step 19
Time to add some shadows! To add shadows, go to View > Shadows. Orbit around to get an idea of the
angle you’ll want for your final composition. Not the look of the shadows for the time of year you want? No
need to worry – that’s what the Shadows Palette is for. To open it, go to Window > Shadows. Once
opened, input the precise date and time, or use the sliders to preview your shadows.
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Step 20
Now we need to get this ready for export. To make things look a little more finalized, we’ll need to hide
our axes and edges. To do this, go to View > Axes and uncheck it. To uncheck your edges go to View >
Edge Style > Edges.
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Step 21
That looks better. Get your text positioned exactly how you want it to look, making sure the entire piece
fits on your screen. When you’re satisfied, go to File > Export > 2D Graphic. A dialog box shows up, and
you have 3 options to choose from: jpeg, png, and tiff files. I’ve selected a tiff file. If you click "Options…"
a second box shows up where you can specify exact dimensions and resolution, as well as rendering
options. I’ve chosen the settings below for mine. The width and height are the default screen size, which
is why making sure your entire piece fits on your screen is important. For whatever reason, even if you
put in a resolution other than 72ppi, it will still open as 72ppi. Luckily, it’ll be large enough where you can
adjust it in Photoshop when you scale it down. When you’re ready, Export away. Time to take it into
Photoshop!
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Step 22
Now that we’re in Photoshop, open your 2D graphic file from where you saved it. Next, let’s get our
canvas a little easier to work with. To change the canvas size, go to Image > Canvas Size and add a bit
more height, then crop (c) at the resolution you prefer (mine’s at 150ppi). Name your layer Original.
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Step 23
Let’s take care of those horrible green shadows. Select them using your magic wand tool (w) and shiftclick to add each additional piece. Now that they’re all selected, go to Select > Modify > Expand. Input
1px and hit Ok.

Step 24
Now hit Delete or Backspace to remove the green shadows from the original image. Keeping your
selection, create a new layer and call it Main Shadows. Make your background color black, then hit
Cmd/Ctrl + Backspace to fill the selection with black. Set this layer’s opacity to 40%.
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Step 25
Now we need to bring in a background. I’ve used a grass texture which you can get here. Place the
image in a layer below Original and name it Grass.

Step 26
It’s pretty obvious our grass needs some darkening up here. Create another layer right on top of it, fill it
with black, and name it Dark. Set this layer’s opacity to 35%.
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Step 27
Following the direction of the shadows off of the text, and to make the focal point more concentrated on
the text, create a new layer above Dark. Create additional shading to the grass just above the text using a
large soft brush. Name this layer Extra Dark and set the opacity to 25%.

Step 28
To get the grass following the same perspective as our letters, we need to distort it. Cmd/Ctrl + T to free
transform your grass, right click, and choose Distort. Grab the corner nodes to follow the angles of the
first and last letters for each side.
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Step 29
Now to juice up these letters! Cmd/Ctrl-click the Original’s layer thumbnail to select its content. Create a
brightness and contrast adjustment layer, setting brightness to -31, and contrast to 100.

Step 30
Now we need to add a couple of layer styles to the Original layer. Double click the layer, and check Drop
Shadow. Add the settings below. I’ve turned off global light and chosen an angle to make the drop
shadow match the Original’s shadows, so choose an angle for your own that will best match up with
yours.
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Step 31
Next, check Inner Shadow. We’re just going to add a very, very subtle shadow that will be apparent on
the bottom edges of all the letters just to give it a little extra depth. Add the settings below, but adjust the
angle for your own piece to match that bottom edge.

33

Step 32
Next, crop your image for your final composition or look.

34

Conclusion
Create a new layer at the very top and with a soft brush, lightly shade the outer edges and corners for a
final touch. Google Sketchup is a great alternative to the Repousse tool, especially if you don’t have CS5,
and there are plenty of video tutorials on Youtube for learning new features. Thanks for reading!
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My Story With Sketchup
- By Suresh Tamang
Hi friends, me Suresh Tamang. I am from country of Himalayans “NEPAL”. I am the Managing Director of
Chitwan Design Consultant (P) Ltd, Chitwan, Nepal. I am so happy to share my story about “My favorite
Software AutoCAD, sketch up and V-ray engine.”

Well, I was raised in engineering environment. My father was civil contractor in the local area of Nepal so
he used to have a lot of building drawings in his office. Seeing those drawings I used to be very curious,
being inspired by my father’s work I used to copy (trace) sketch, in spite of the knowledge of engineering
and architecture. My colleagues, elders inspired and motivated me for the great wishes in future. After
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completing my high school education, I assisted my father in his job. Being an interested fellow in
engineering I started my drawing profession in 1996 A.D., back then drawings was done by pencil. In the
mid of 2001A.D. I heard about the CAD, since then I used CAD to draw building sketch.

I entered in the world of 3D-Design in 2006 A.D. I thought to get training in 3D-Max, but my colleague Ar.
Rara K.C. told me about Google Sketchup. I started searching everywhere about sketchup, I googled,
watched youtube videos and read many tutorials on sketchup to gain as much knowledge as I can get. I
can say I learn it on my own effort. The total credit goes to youtube and google which helped me a lot.
Since then I used sketchup as my primary software to make 3D model, and I have never stopped
learning.
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Since 2009, “Chitwan Design Consultant” (P) Ltd. has been established by jointly (Me and My collogue
Er. Sanjay Chandra Neupane) in Chitwan, Nepal. Up to now we have developed many designs for our
company by sketch up. We believe in team work “A Complete Engineering Solution and clients’
satisfaction is our satisfaction” is our motto.
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Ultimately, I would like to thank to technology, sketchup which helped me to be a professional, improve
my ideas and help to show my quality. “Sketch up your space “, is highly appreciated to provide
opportunity to share my feeling.
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“Abilities, curiosity and morality derive to be successful person”:- Mr. Sherman Tamang, social worker
(My father)
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The Making of Conference Room
Using Sketchup Vray and Photoshop
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By: LIM RADY
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Materials
Clear Glass

Diffuse I used Blue. And Transparency I used color RGB=230
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Add Reflection > Fresnel >IOR= 3 and Refract IOR =3.

Noise Glass
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Noise Glass I use the same of clear glass just add Bump >niose size 0.0001.

Table Laminate

Diffuse I used color R=238 G=229 B=211
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Add Reflection > Fresnel >IOR= 1.55 and Refract IOR =1.55

Leather Chair
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Diffuse and Map bump I used the sameTexmap. And Bump =1.2
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Add Reflection > Fresnel >Perpendicular color Val=140.
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Crome
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Diffuse I used color Val=193

Add Reflection > Fresnel >IOR=7 Refract IOR=7

Carpet

Diffuse and Displacement I used the same Texbitmap. And Displacement =0.4
52

White board
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Emmesive

IES light
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Render Option
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58

Raw Render
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Photoshop

Ctrl+L to control level of color.
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Ctrl+U to control Hue/Saturation of color.
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Post Product
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Sketchup and Photoshop compliment to each other
- By Rajib Dey
The sketchup users can make some grand image effects while combining SketchUp with other design
software like photoshop . The users can apply the fog setting in SketchUp to generate a depth map which
one can utilize in Photoshop resulting very fascinating effects.

The following video tutorial will provide step by step guidance on how to apply sketchup and photoshop
for lens blur effect.

http://www.youtube.com/embed/fZl_xDhuTFc?feature=player_detailpage
The sketchup and photoshop are also very useful for interior drawing concepts. The interior designers
can apply hand sketching techniques with digital tools by combining sketchup and photoshop together to
make stunning design and presentations. There is a beautiful book alias “Interior Design Using Hand
Sketching, SketchUp, and Photoshop” written by Steven H. Mcneill AIA, LEED AP and Daniel John Stine
CSI, CDT which will focus on how to utilize Google sketchup 8 and Adobe Photoshop CS5 to optimize
design and presentation skills.
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The users can also use phtoshop in tandem with sketchup to generate 3D text (3D typography) for
architectural application.
One can render a sketchup file in photoshop. Sketchup is very useful for mapping the textures, some
transparencies and the shadows, applying separate layers for line, shadow and color etc. With the three
dimensional modeling program of sketchup, the digital designer get the ability to rapidly acquire several
perspectives of a solitary model and improve them beyond their basic forms by applying the commanding
rendering capabilities of Photoshop. The capability to render a perspective to attain a photorealistic
quality, a watercolor appearance, or anything in between, makes the new digital artist a much-desired
commodity. For creation of digital scene, applying some Photoshop skills to post-rendered images
makes a world of a difference. While rendering camera position is very vital. The SKP users utilize
photoshop to easily correct perspective.
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SketchUp is a master tool for non-photorealistic output, but to polish your images with greater superiority
one can utilize Photoshop to make some attractive effects. The users can go with versatile display modes
of sketchup to produce some different styles which can be combined with photoshop to achieve fast and
effective results.
The users can generate a model with SketchUp & transform it to realistic applying Photoshop. SketchUp
facilitates to form 3D textured model wherever Photoshop enhances it realistically or even artistically. A
variety of advanced tools of Photoshop allow the users to create such models or photos or something like
that just what you exactly want.
If we evaluate SketchUp with pencil or brush through which we make a picture, then Photoshop is the
color which creates a picture just pragmatic. While SketchUp makes our dreams true, Photoshop turns
the truth rather better condition which is just beyond our expectation or rather to say Photoshop renovate
our dream in real.
Photoshop is the other name of completeness. It alters the ugly or uncomfortable things into beautiful &
comfortable one. Briefly, the combination of SketchUp & Photoshop enables us feeling relieved & relaxed.
Some useful reference
Sketchup and photoshop
http://www.alexhogrefe.com/sketchup-to-photoshop-quick-re/
Rendering with SketchUp and Photoshop
http://www.scribd.com/doc/40072009/%D0%A0%D0%B5%D0%BD%D0%B4%D0%B5%D1%80%D0%B8
%D0%BD%D0%B3-SketchUp-%D0%B2-Photoshop
How to create a sketchy shadow using SketchUp + Photoshop
https://sketchuptips.wordpress.com/2012/02/23/how-to-create-a-sketchy-shadow-using-sketchupphotoshop/
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A Guidebook to RendeRinG with Sketchup And photoShop
http://lda.ucdavis.edu/people/2007/AHaskin.pdf

DEALING WITH UNITS IN SKETCHUP
- By Thomas Thomassen
There are extensions to the base classes in SketchUp’s Ruby API which often new SketchUp plugin
developers overlook. If you aren’t aware of them you might find yourself reinventing many features of the
SketchUp API which already exists. There is very little you need to do to deal with units, SketchUp
does most of the work.

Internally SketchUp uses inches as system unit. All 3D coordinates in the model data are in inches – no
exceptions! This internal units are converted to model units only when presented in the UI. Similarly, all
user input is immediately converted to internal units. Your plugin should do this to!
Internal Units to Model Units
To convert an internal unit, to a string in model unit, ensure that your length value is of
the Length class.Length.to_s – which is the same as Sketchup.format_length( value ) - formats the
internal unit into a user friendly string using the model settings and user locale.
Float and Length
Length is a sub-class of Float. Geom::Point3d and Geom::Vector3d will return Length objects for it’s
coordinate components.
Note that using Length for arithmetic operations will return Float objects. So make sure you know
whether you have a Float or Length object when you eventually want to present that value to the
UI.Float.to_l will give you a Length object when you need to.
Model Units to Internal Units
The String class takes care of converting model units to internal units in the form of String.to_l. If you
have a string "50".to_l and the model units is millimetres it will assume the numeric value in the string
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is millimetres. But at the same time the string can contain unit indicators to override this: "50m".to_l will
be treated as 50 metres regardless of model unit settings. This is useful for processing VCB input for
instance as the user can then input lengths in any units supported by SketchUp – just like the native tools
and you don’t have to do anything more than .to_l.
UI.inputbox
The input box in SketchUp will actually try and do the conversion between model units and user input
strings for you if you set it up correctly. If you give it Length objects as default values it will automatically
convert the values into model unit strings in the UI of the dialogue and back into Length for the return
values.
1
2
3
4
5
6
7
8
9
10

prompts = ['Name', 'Width', 'Height']
defaults = ['My Own Square', 5.m, 2.m]
input = UI.inputbox( prompts, defaults, 'Create Square' )
# User enters Width: 300cm, Height 4
p input
# => ["My Own Square", 118.110236220472, 157.48031496063]
p input.map { |n| n.class }
# => [String, Length, Length]
p input.map { |n| n.to_s }
# => ["My Own Square", "3000mm", "4000mm"]

As you can see from this example, SketchUp does all the work – you do not need to convert to and from
string yourself.

Note that this doesn’t work so well for floats, as Ruby assumes floats are using period for decimal
separator even if the user locale uses comma. If the user uses a comma for
decimal separator for Float values you get anArgumentError when SketchUp tries to convert
theString back to Float. This error is unique to UI.inputbox – when you otherwise convert for
instance '0,8'.to_f you will get 0.0 without any errors.
Storing Unit Data
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Because users have different decimal separators depending on their locale, never store unit data as
formatted strings! Don’t write Length values out as length.to_s – instead convert it to a Float. That
way you can be sure that you can read the data back regardless of the locale of the target system
becauseFloat.to_s always use period as decimal separator – and String.to_f always expect a period. To
load a unit from a float stored as string correctly you use: string.to_f.to_l.
A string like "10,5m” can only be parsed with .to_l correctly on systems with comma as decimal separator
- similarly "10.5m" can only be parsed with .to_l correctly on systems with period as decimal separator.
Mixing up this and you end up with ArgumentError.
Angles
Internally SketchUp uses radians instead of degrees. The Numeric class is extended to provide easy
conversions so you can type stuff like 75.degrees which will return 75 degrees in radians - similarly you
can type 0.25.radians to return a radian value to degrees. These methods also exists
asSketchUp.format_degrees and Sketchup.format_angle.
Areas
You also have Sketchup.format_area which will take a value representing an area inch-squared and
format it into model units. But the problem arise when you want to convert the other way around.
Currently, SketchUp 8 M3, there is no methods for converting area strings in model units to internal units.
You have to craft your own. This is not so easy because some user locales uses comma as decimal
separator – and there is no method that returns this in SketchUp. But you can hack it.
SketchUp Units and Locale Helper Library
I’ve collected most of my units and locale methods into an example library on GitHub. Feel free to use it
for whatever you need and please push back improvements.

SketchUp Units and Locale Helper Library on GitHub
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Making Grass with Sketchup Fur Plugin
- By Diocera Jasonr
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Create HDRI Environment with Sketchup
- By Jason R Diocera
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Ron Paulk’s Super Mobile Woodshop is complete,
and He’s Postedthe Sketchup Plans for Free
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Download
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When last we looked in on Washington-based builder Ron Paulk, he was on the verge of completing his
kick-ass Mobile Woodshop. Contained inside a 1,000-cubic-foot box truck, Paulk's comprehensive design
ingeniously incorporates every major power tool a contractor would need, features copious parts-andmaterials storage, and is loaded up with a plethora of clever design solutions.
Since

our

initial

coverage,

Paulk's

uploaded

a

video

tour

of

the

completed

project:

http://www.youtube.com/watch?v=iuhDERZbBeY&feature=player_embedded
Even better, Paulk has uploaded his complete Google Sketchup plans free of charge. We admire both
Paulk's design ingenuity—as one example you can see in the video tour above, he wisely eschewed
expensive drawer slides and found simple dados in plywood to be a superior solution—and his generosity
in sharing the final design, which is the result of not only the several months he put into drawing up and
constructing the project, but of his decades of experience in building things. The plans are available here,
and our thanks go out to Paulk.

Build 3D models for free with SketchUp
SketchUp was a Google product until recently; it's now part of Trimble. Google's ownership, plus a freeto-use version of the aplication has made it popular with millions of people and, fortunately, there's still a
free

version.

Although very powerful, SketchUp is easy to use - once you know how, of course. You can use it for
various things, including creating 3D models of houses, furniture or just about anything - even 2D
floorplans.
We can only scratch the surface of SketchUp's capabilities here, but armed with the basic knowledge of
how to use the main tools, you'll be able to quickly draw objects to scale in real-world dimensions.
Although you can use SketchUp on a laptop (the system requirements aren't demanding) you really need
a proper mouse with a clickable scroll wheel to be efficient, particularly for moving around your models.
Otherwise, you'll be forever clicking on the zoom, pan and orbit tools to move and resize the model on
screen.
One of the key things to learn about SketchUp is that you'll use the keyboard to draw a line or rectangle to
a certain length or size. When you begin drawing a line in a certain direction, simply type its length, for
example '0.62m' and press Enter. You could alternatively type 0.62 if you've picked a template with units
set to metres. However, you can type '62cm' or '620mm' to achieve a line of the same length.
If you follow our tutorial here, you'll end up with a basic model of a house. You can add textures using the
Paint Bucket tool, then choose from the selection of materials, such as bricks or roofing. If you plan to use
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textures, make sure you draw your model to actual size otherwise bricks, for example will appear too
large or too small.
To get started, download and install SketchUp from www.sketchup.com. Click the Download SketchUp
button, then the Download SketchUp link. Avoid the SketchUp Pro button, which is an eight-hour trial.

How to create a 3D model with SketchUp
Step 1. Launch SketchUp and click the Choose Template button on the welcome screen. Choose
'Architectural Design - Millimeters' and click Start using SketchUp. The main application will load with a
3D view.

Step 2. Click Camera > Standard Views > Iso, then click the Rectangle tool (third from left) and click,
move your mouse to draw the rectangle, then click again to finish. Most tools in SketchUp work this way there's minimal click-and-drag.
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Step 3. Select the Push/Pull tool (press P) and click inside your rectangle and move your mouse upwards
to 'pull' the surface and make a 3D box. You can make objects a specific size by starting to draw, then
typing in the number and pressing Enter.

Step 4. Using the rectangle tool (R) again, draw another rectangle on one of the box's surfaces. SketchUp
snaps to edges and endpoints, making it easy to line elements up. You can find the midpoint of a line by
hovering the cursor near it.
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Contines on next page
Step 5. To look around your model, use the Orbit, Pan and Zoom tools. Instead of selecting them from the
toolbar, click your mouse wheel and drag to orbit your model, roll the wheel to zoom in and out, and click
the wheel while holding Shift, then drag to pan.

Step 6. SketchUp will automatically snap to the three axes (red, blue or green) to help you draw
accurately. Select the Line tool (P) and orbit the model to better see the top. Draw a line between two
midpoints to divide it in half.
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Step 7. Highlight the line using the Select tool (Space) and use the Move tool (M) to create a roof. Make
sure the line stays snapped to the blue axis to ensure the apex remains in the middle, and not skewed to
one side.

Step 8. The offset tool is one of the most useful. Orbit the model to look at it from below and use the
Offset tool (F) to create an offset slightly in from the edges. With the Push/Pull tool (P), push the offset
upwards to just below the roofline to create an overhang.
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Step 9. You can use the Pencil, Rectangle, Offset and Push/Pull tools to create windows and doors with
ease. When you're finished, save your model. You can export it using the File > Export menu. Commonly,
people export 3D models to Google Earth.
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SKETCHUP SHOWCASE FEATURE
Google SketchUp Showcase has posted some of the best SketchUp projects from around the world on
their website, and CA Rampworks earned a spot. The showcase displays different projects in different
areas of expertise that has utilized Google Sketchup. The projects range from a Floating Sunglass Hut to
Bonsai Bench Building. California Rampworks designer, Dug Ketterman, was chosen for the key role that
Sketchup played in the design and development of the XGames 17: Street and Park
Course. Ketterman used SketchUp for the conceptual design process, structural engineering of the
support structure, material estimation, construction documents, branding and the assistance with field
measurements and support. Read the article on The SketchUp Showcase to learn more about the design
process and evolution behind such an increadible event.

Sketching out the flow lines is the way Dug always begin any flow park design. This shows the basic
direction the skaters will be traveling within the given build area.
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One of the numerous concepts that were created during the design and development phase.

One of the original renderings created as a presentation to the X Games for the 2011 Park Course
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Aerial Photo of the ESPN X Games 17 during live broadcasting of the BMX finals
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e-on software intros LumenRT 3
e-on software of Oregon, the makers of Vue series rendering software for digital nature, have announced
the immediate availability of LumenRT 3 Review. LumenRT is a rendering plugin product for SketchUp
and works on both Windows and Mac, in both the free and pro versions of SketchUp.

LumenRT 3 – What’s New
LumentRT 3 ads powerful new features including “immersive media” elements like flying birds, moving
trees and moving people, to name a few. Plus the program allows you to experience this immersive
media at various speeds of interaction, from produced normal speed animations to still-to-walking-torunning speed client controlled walk-thrus.

01 - LumenRT 3 offers immersive media features. Powerful plugin adds much to SketchUp users. (image
courtesy of e-on software, all rights reserved)
This means you can choose to walk around your SketchUp scene with LumenRT 3 and trees will blow in
the wind, while you are using the walk-thru tool and even in a stopped position. The effect is that you are
inhabiting a living environment with real wind, real people and so on. In brief, here is what is new:
•

Nature elements (trees blowing in the wind, sitting-walking-talking people, shiny cars, animals, etc)

•

Faster processing (high quality indirect light is generated 10x faster)

•

Super simple operation of navigation

•

One-click instant viewing

•

Rich material effects

•

Better real-time navigation on less capable hardware and entry level video boards

LumenRT 3 will retail for 295.USD and the Content Pack is 195.USD. You can buy a bundle and save
100.USD. There are educational licenses as well and current LumenRT 1 and LumenRT 2 users can
upgrade for free. LumenRT is a 32 and 64-bit application designed for both Windows and Mac and works
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as a plugin inside both SketchUp Free and SketchUp Pro (versions 7 and 8). A version for Autodesk
Revit and Autodesk 3ds Max is currently in development and expected to be released in quarter 3 or
2012.
The free upgrade for existing uses times out on 15 Sep 2012, so please act now to grab your LumenRT 3
upgrade. To learn more or download the trial software please go here: http://www.lumenrt.com/

Arts Council will hold a hands-on workshop using
SketchUp

The Arts Council will hold a hands-on workshop using the SketchUp program for 3D modeling in October
and November.
SketchUp is a free program designed to help users create, modify, and share 3D models for a wide range
of uses including interior design, furniture or cabinetry design, set design and video game design.
The four-part workshop will be led by Huntsville furniture and wood artist J. Leko, who uses the SketchUp
tool to design new pieces and communicate his designs to customers.
Workshop sessions will be from 1 to 3 p.m. on Oct. 21 and 28 and Nov. 4 and 11. Participants should
bring their own computer with SketchUp loaded (available online for free download) and a three-button
mouse. The workshop fee for the four sessions is $180. Class size will be limited to 10 participants.
Preregistration

for

the

workshop

is

required.

emailghurst@artshuntsville.org to register.
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Call

Gina

Hurst

at

256-519-2787

or

